Skip to content

哪些路由器对OpenWrt支持较好

可以到openwrt官网查询支持openwrt的路由器,地址如下:
http://wiki.openwrt.org/toh/start

OpenWrt 可以被描述为一个嵌入式的 Linux 发行版,(主流路由器固件有 dd-wrt,tomato,openwrt三类)而不是试图建立一个单一的、静态的系统。

以TP-LINK WR703N 为例简单介绍一下刷openwrt流程:
1、下载安装
访问WR703N在OpenWrt的Wiki页,然后在Flashing一节中找到下载链接:squashfs-factory.bin。
进入路由器管理界面,出厂配置为http://192.168.1.1,用户名和密码均为admin,然后进入固件更新,选择下载的文件,然后更新。等待一段时间(~~2min),然后重启路由。
2、初始配置
用一根网线将路由器的Lan口和你电脑相连,电脑上设置为DHCP模式。然后运行cmd.exe
输入telent 192.168.1.1
成功后将出现OpenWrt的欢迎界面。
然后更改root密码:
输入passwd
更改root密码后dropbear(SSH 服务)就运行了,输入exit退出telent。
以后就可以通过ssh管理OpenWrt。
3、网络配置
OpenWrt官方的固件是不带LuCl的,所以初始的网络设定需要在命令行下完成
下载ssh连接工具putty
输入192.168.1.1
点击open,如果弹出窗口点是即可。
输入用户名root回车 然后输入你刚刚设定的密码
然后用vi修改相关配置。
首先修改/etc/config/wireless文件
输入vi /etc/config/wireless回车
注释掉# option disabled 1
按i进入修改模式
改好后按esc,然后输入:wq保存退出
然后修改/etc/config/network文件。
首先修改lan接口配置,注释掉此行:
# option ifname 'eth0'
然后增加wan接口,如果你上级网络是DHCP的,则文件的末尾添加:
config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'
如果你上级网络是静态IP,则在文件的末尾添加:
config interface 'wan'
option ifname 'eth0'
option proto 'static'
option ipaddr '10.22.33.124'
option netmask '255.255.255.0'
option gateway '10.22.33.1'
option dns '202.113.16.10'
然后将路由器的Lan/Wan口接到上级网络中,重启路由器。
这时便可以通过电脑寻找SSID为 OpenWrt的无线网络,加入后电脑便可以通过703N上网了。
接着ssh 到路由器
登陆后输入opkg update
opkg install luci
/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start
就有luci(WEB)界面了~
完后就可以通过浏览器访问192.168.1.1来配置路由器了

Tags:

发表评论